Як зводити в дробову ступінь?

Як зводити в дробову ступінь?

Для зведення числа в ступінь в 1С 8. х є вбудована функція pow (підстава, ступінь); Повертає результат піднесення заснування в зазначену ступінь. Код 1C v 8. х / / Зведемо число 5 в ступінь 3Результат = pow (5, 3) ;/ / Результат = 125 / / Обчислення об’єму кулі за значенням радіуса i = 3. 1415926535897932; Радіус = 3; V = 4 * i * ow (Радіус, 3) / 3; Повідомити (Обсяг кулі з радіусом + Радіус + дорівнює + Формат (V, ЧДЦ = 2)); / / Приклад розрахунку складного відсотка використовуючи OWФункція СложнийПроцент (Кредит, Ставка, Термін = 1) Повернення Кредит * ow (1 + Ставка/100, Термін); КонецФункции

Код 1C v 7. x / / В діалоговій формі — Ліміт, Точність, СамоЧісло (невід’ємне) та / / Ступінь. Функція ЦелаяСтепень (а, б) Результат = 1; Для К = 1 По б Цикл Результат = Результат * а; КонецЦікла; Повернення Результат; КонецФункцііФункція ЗнаковПослеТочкі (Стор) Перем К; Номер = Знайти (Стор,.); Якщо Номер = 0 Тоді Повернення 0; КонецЕсли; НачалоНулей = Номер +1; Для К = Номер +1 За СтрДліна (Стор) Цикл Якщо Сред (Стор, К, 1) 0 Тоді НачалоНулей = К; КонецЕсли; КонецЦікла; Повернення Макс (НачалоНулей-Номер, 0); КонецФункцііФункція Знак (Ч) Якщо Ч = 0 Тоді Повернення 0; ІначеЕслі Ч 0 Тоді Повернення 1; Інакше Повернення -1; КонецЕсли; КонецФункцііФункція Корень10ВСтепені (Ч, Ступінь) Перем а, б; Якщо Ступінь 0 Тоді Повідомити (Ступінь 0 ); КонецЕсли; _10ВСтепені = ЦелаяСтепень (10, Ступінь); Якщо _10ВСтепені 1 Тоді а = 0; б = Ліміт; Реза = Ч-ЦелаяСтепень (а, _10ВСтепені); резба = Ч-ЦелаяСтепень (б, _10ВСтепені); Поки 1 = 1 Цикл Поточне = (а + б) / 2; Рез = Ч-ЦелаяСтепень (Поточне, _10ВСтепені); Якщо Знак (Рез) * Знак (різані) 0 Тоді б = Поточне; Інакше а = Поточне; КонецЕсли; Якщо (а- б Точність) І (а-б-Точність) Тоді Повернення Поточне; КонецЕсли; КонецЦікла; ІначеЕслі Ступінь = 1 Тоді Повернення Ч; Інакше Повернення 1; КонецЕсли; КонецФункцііФункція Степень_xyz (f, x, y, z) Повернення ЦелаяСтепень (f, x ) * ЦелаяСтепень (f, y) / Корень10ВСтепені (f, z); КонецФункцііФункція ПоложительнаяДробнаяСтепень (а, ПоказательСтепені) Перем Знак; ЦелаяЧасть = Число (Рядок (Цел (ПоказательСтепені))); ДрЧасть = Сред (ПоказательСтепені, СтрДліна (Рядок (ЦелаяЧасть )) +2); ВерхДробной = Число (СтрЗаменіть (ДрЧасть,.,)); Якщо ВерхДробной 0 Тоді ДлинаДробной=ЗнаковПослеТочки(Строка(ПоказательСтепени)); Інакше ДлінаДробной = 0; КонецЕсли; x = ЦелаяСтепень (а, ЦелаяЧасть) * Корень10ВСтепені (ЦелаяСтепень (а, ВерхДробной), ДлінаДробной); Повернення x; КонецФункцііФункція Ступінь (а, б) Якщо б 0 Тоді наша = 1 / а; НашаБ = -б; Інакше наша = а; НашаБ = б; КонецЕсли; Повідомити (ПоложительнаяДробнаяСтепень (наша, НашаБ)); Повернення ПоложительнаяДробнаяСтепень (наша, НашаБ); КонецФункцііЛіміт = 9999999; Точність = 0.

001 ;/ / повідомив Пудель.

Як зводити в дробову ступінь?

Сподобалася стаття? Поділися нею з друзями!




Комментарии закрыты